summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
2 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 757d33ede0b4..1e99f46155de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pytest-md-report
pkgdesc = Pytest plugin to create a report in Markdown table format
- pkgver = 0.2.0
- pkgrel = 2
+ pkgver = 0.3.0
+ pkgrel = 1
url = https://github.com/thombashi/pytest-md-report
arch = any
license = MIT
@@ -16,10 +16,10 @@ pkgbase = python-pytest-md-report
depends = python-pytest
depends = python-tcolorpy
depends = python-typepy
- source = python-pytest-md-report-0.2.0.tar.gz::https://files.pythonhosted.org/packages/source/p/pytest-md-report/pytest-md-report-0.2.0.tar.gz
- source = python-pytest-md-report-0.2.0.tar.gz.asc::https://files.pythonhosted.org/packages/source/p/pytest-md-report/pytest-md-report-0.2.0.tar.gz.asc
+ source = python-pytest-md-report-0.3.0.tar.gz::https://files.pythonhosted.org/packages/source/p/pytest-md-report/pytest-md-report-0.3.0.tar.gz
+ source = python-pytest-md-report-0.3.0.tar.gz.asc::https://files.pythonhosted.org/packages/source/p/pytest-md-report/pytest-md-report-0.3.0.tar.gz.asc
validpgpkeys = BCF9203E5E80B5607EAE6FDD98CDA9A5F0BFC367
- sha256sums = c129cebee45f9acb2fc26631ca5845f2d2deabbc134789f163224a347a0f9f5f
+ sha256sums = adaf3c5971bafb11d28ce732ead7588efa4aa4d96fbba96afac65c90b69d0255
sha256sums = SKIP
pkgname = python-pytest-md-report
diff --git a/PKGBUILD b/PKGBUILD
index 5cce2c57e036..10e80d33c97a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
pkgname=python-pytest-md-report
-_name="${pkgname#python-}"
-pkgver=0.2.0
-pkgrel=2
+_pkg="${pkgname#python-}"
+pkgver=0.3.0
+pkgrel=1
pkgdesc='Pytest plugin to create a report in Markdown table format'
arch=('any')
url='https://github.com/thombashi/pytest-md-report'
@@ -12,28 +12,29 @@ license=('MIT')
depends=('python-pytablewriter' 'python-pytest' 'python-tcolorpy' 'python-typepy')
makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
checkdepends=('python-pytest' 'python-dateutil' 'python-pytz')
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
- "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz.asc")
-sha256sums=('c129cebee45f9acb2fc26631ca5845f2d2deabbc134789f163224a347a0f9f5f'
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkg::1}/$_pkg/$_pkg-$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/${_pkg::1}/$_pkg/$_pkg-$pkgver.tar.gz.asc")
+sha256sums=('adaf3c5971bafb11d28ce732ead7588efa4aa4d96fbba96afac65c90b69d0255'
'SKIP')
validpgpkeys=('BCF9203E5E80B5607EAE6FDD98CDA9A5F0BFC367')
build() {
- cd "$_name-$pkgver"
+ cd "$_pkg-$pkgver"
python -m build --wheel --no-isolation
}
check() {
- cd "$_name-$pkgver"
- PYTHONPATH=./ pytest -x tests
+ cd "$_pkg-$pkgver"
+ PYTHONPATH="$PWD" pytest -x tests
}
package() {
- export PYTHONHASHSEED=0
- cd "$_name-$pkgver"
- python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 'README.rst' -t "$pkgdir/usr/share/doc/$pkgname"
- install -Dm644 'LICENSE' -t "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname"
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s "$_site/${_pkg//-/_}-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
}
# vim: ts=2 sw=2 et: