summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a634813e0ac..eb670debad32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,9 @@ pkgbase = python-python-sat
url = https://github.com/pysathq/pysat
arch = any
license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-six
source = https://files.pythonhosted.org/packages/source/p/python-sat/python-sat-0.1.8.dev9.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 6f5e8a4574b3..708367926519 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,14 @@ license=(GPL3)
depends=("python" "python-six")
source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha512sums=('53eef81c990868cd39a95da91e3f7789884f590d3b199cd9ed4089cebef39bc2d5d26c80db856dbb8c05436358db7e6bda5d894ece524d11455bb77f25006e6b')
+makedepends=(python-build python-installer python-wheel)
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/python-sat-$pkgver"
- python setup.py install --root $pkgdir
+ cd "$_pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}