summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD11
-rw-r--r--pythonz.sh2
4 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a58f2fb0f3b9..40e8bb094439 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pythonz
pkgdesc = Python installation manager supporting CPython, Stackless, PyPy and Jython
pkgver = 2.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/saghul/pythonz
arch = any
license = MIT
@@ -13,8 +13,7 @@ pkgbase = python-pythonz
conflicts = python-pythonz-bd
source = https://github.com/saghul/pythonz/archive/pythonz-2.0.1.tar.gz
source = pythonz.sh
- md5sums = f421f13c6c24685d673c462e9771ada6
- md5sums = b600ba39aed7de0e1ed2ed42ff11908c
+ sha256sums = 36980ef3b0ad632fb9596c60eb32a3275b2ef3641b07b376924d06ff79b4d539
+ sha256sums = 43f32208f3fc7a2dce93eef8685618c06053c7ed8baed72caef4c4e10d788b0f
pkgname = python-pythonz
-
diff --git a/.gitignore b/.gitignore
index 2b1dd93316ea..8e6be211f0e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,8 @@
-*
-
-!PKGBUILD
-!.SRCINFO
-!.gitignore
+*.bak
+*.gz
+*.xz
+*.zst
+*.sh
+src
+pkg
!pythonz.sh
diff --git a/PKGBUILD b/PKGBUILD
index 4caf15011b99..5c746aac9177 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
pkgname='python-pythonz'
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python installation manager supporting CPython, Stackless, PyPy and Jython"
url="https://github.com/saghul/pythonz"
arch=('any')
license=('MIT')
depends=('python' 'python-resumable-urlretrieve')
makedepends=('python' 'python-setuptools')
+optdepends=('libtinfo: for running pypy')
conflicts=('python-pythonz-bd')
source=(
"https://github.com/saghul/pythonz/archive/pythonz-$pkgver.tar.gz"
"pythonz.sh"
)
-optdepends=('libtinfo: for running pypy')
+sha256sums=('36980ef3b0ad632fb9596c60eb32a3275b2ef3641b07b376924d06ff79b4d539'
+ '43f32208f3fc7a2dce93eef8685618c06053c7ed8baed72caef4c4e10d788b0f')
package() {
cd "$srcdir/pythonz-pythonz-$pkgver"
- PYTHONZ_ROOT="$pkgdir/opt/pythonz" python -c "from pythonz.installer import install_pythonz ; install_pythonz()"
+ PYTHONZ_ROOT="$pkgdir/usr/local/pythonz" python -c "from pythonz.installer import install_pythonz ; install_pythonz()"
mkdir -p $pkgdir/etc/profile.d
install $srcdir/pythonz.sh $pkgdir/etc/profile.d
}
-
-md5sums=('f421f13c6c24685d673c462e9771ada6'
- 'b600ba39aed7de0e1ed2ed42ff11908c')
diff --git a/pythonz.sh b/pythonz.sh
index 82933645c746..116f5bd24557 100644
--- a/pythonz.sh
+++ b/pythonz.sh
@@ -1,4 +1,4 @@
if [ -n "${BASH_VERSION:-}" -o -n "${ZSH_VERSION:-}" ] ; then
- export PYTHONZ_ROOT=/opt/pythonz
+ export PYTHONZ_ROOT=/usr/local/pythonz
source "${PYTHONZ_ROOT}/etc/bashrc"
fi