summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc122c3ed701
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pytrec-eval
+ pkgdesc = The smartest command line arguments parser in the world
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/cvangysel/pytrec_eval
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = python-setuptools
+ depends = gcc-libs
+ source = https://files.pythonhosted.org/packages/36/0a/5809ba805e62c98f81e19d6007132712945c78e7612c11f61bac76a25ba3/pytrec_eval-0.4.tar.gz
+ sha256sums = 40b72e90f59751db3c7e385d3797849f6bc634ab07beb398b84301e925f54fb9
+
+pkgname = python-pytrec-eval
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eed05aa3774
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ryan Gonzalez <rymg19@gmail.com>
+
+pkgname='python-pytrec-eval'
+pkgver=0.4
+pkgrel=1
+pkgdesc='The smartest command line arguments parser in the world'
+arch=('any')
+url='https://github.com/cvangysel/pytrec_eval'
+license=('MIT')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+depends=('gcc-libs')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/36/0a/5809ba805e62c98f81e19d6007132712945c78e7612c11f61bac76a25ba3/pytrec_eval-0.4.tar.gz")
+sha256sums=('40b72e90f59751db3c7e385d3797849f6bc634ab07beb398b84301e925f54fb9')
+
+
+build(){
+ cd "pytrec_eval-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "pytrec_eval-${pkgver}"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}