summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD32
3 files changed, 51 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed65a0b65b0b..442ce83d73d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = python-pyvidia
pkgdesc = NVIDIA driver version detector for Linux
pkgver = 1.0.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/ntpeters/pyvidia
arch = any
license = MIT
- depends = python
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-lxml
depends = python-beautifulsoup4
- provides = pyvidia=1.0.1
- source = https://pypi.python.org/packages/source/p/pyvidia/pyvidia-1.0.1.tar.gz
+ depends = python-six
+ source = python-pyvidia-1.0.1.tar.gz::https://files.pythonhosted.org/packages/source/p/pyvidia/pyvidia-1.0.1.tar.gz
+ source = LICENSE
sha256sums = b2b2f04c6f2b873e7c290a45db0b3e85e9ae3daac9b643d48966b23439c4fdea
+ sha256sums = 35e680322daa98915180af76a4bacd02c1dc65c6da057f7d26ada64c571113e4
pkgname = python-pyvidia
-
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1d316da61d62
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+
+Copyright (c) 2015 Nate Peterson
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
index 96f66b0fe771..d36df9ae6da4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
-# Maintainer: Javier Tia <javier dot tia at gmail dot com>
-pkgname='python-pyvidia'
-_pipname=pyvidia
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Javier Tia <javier dot tia at gmail dot com>
+
+pkgname=python-pyvidia
+_pkg="${pkgname#python-}"
pkgver=1.0.1
-pkgrel=3
+pkgrel=4
pkgdesc='NVIDIA driver version detector for Linux'
url='https://github.com/ntpeters/pyvidia'
arch=('any')
license=('MIT')
-provides=("${_pipname}=${pkgver}")
-depends=('python' 'python-lxml' 'python-beautifulsoup4')
-source=("https://pypi.python.org/packages/source/p/${_pipname}/${_pipname}-${pkgver}.tar.gz")
-sha256sums=('b2b2f04c6f2b873e7c290a45db0b3e85e9ae3daac9b643d48966b23439c4fdea')
+depends=('python-lxml' 'python-beautifulsoup4' 'python-six')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkg::1}/$_pkg/$_pkg-$pkgver.tar.gz"
+ 'LICENSE')
+sha256sums=('b2b2f04c6f2b873e7c290a45db0b3e85e9ae3daac9b643d48966b23439c4fdea'
+ '35e680322daa98915180af76a4bacd02c1dc65c6da057f7d26ada64c571113e4')
-package() {
- cd "${srcdir}/${_pipname}-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+build() {
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
+}
- # install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+package() {
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}
# vim:set ft=sh ts=2 sw=2 et: