summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a9dc41706c2..670b3387dce9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = python-pyvisa-py
pkgdesc = A pure python backend for PyVISA
- pkgver = 0.7.1
+ pkgver = 0.7.2
pkgrel = 1
url = https://github.com/pyvisa/pyvisa-py
arch = any
license = MIT
makedepends = git
- makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools-scm
- makedepends = python-pytest
+ makedepends = python-wheel
depends = python-pyvisa
optdepends = linux-gpib: gpib instrument support
- optdepends = python-pyserial: interface with serial instruments
- optdepends = python-pyusb: interface with USB instruments
optdepends = python-gpib-ctypes: interface with GPIB instruments
optdepends = python-psutil: discover TCPIP devices across multiple interfaces
- source = git+https://github.com/pyvisa/pyvisa-py.git#tag=0.7.1
+ optdepends = python-pyserial: interface with serial instruments
+ optdepends = python-pyusb: interface with USB instruments
+ source = git+https://github.com/pyvisa/pyvisa-py.git#tag=0.7.2
sha256sums = SKIP
pkgname = python-pyvisa-py
diff --git a/PKGBUILD b/PKGBUILD
index 2fa3e830d430..1b8118ec4d83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Grey Christoforo <first name [at] last name [dot] net>
pkgname=python-pyvisa-py
-pkgver=0.7.1
+pkgver=0.7.2
pkgrel=1
pkgdesc="A pure python backend for PyVISA"
url="https://github.com/pyvisa/pyvisa-py"
@@ -10,11 +10,11 @@ license=('MIT')
arch=('any')
depends=('python-pyvisa')
optdepends=('linux-gpib: gpib instrument support'
- 'python-pyserial: interface with serial instruments'
- 'python-pyusb: interface with USB instruments'
'python-gpib-ctypes: interface with GPIB instruments'
- 'python-psutil: discover TCPIP devices across multiple interfaces')
-makedepends=('git' 'python-wheel' 'python-setuptools-scm' 'python-pytest')
+ 'python-psutil: discover TCPIP devices across multiple interfaces'
+ 'python-pyserial: interface with serial instruments'
+ 'python-pyusb: interface with USB instruments')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
source=("git+$url.git#tag=$pkgver")
sha256sums=('SKIP')
@@ -24,16 +24,11 @@ prepare() {
build() {
cd pyvisa-py
- python setup.py build
-}
-
-check() {
- cd pyvisa-py
- python -m pytest --pyargs pyvisa_py
+ python -m build -w --no-isolation
}
package() {
cd pyvisa-py
- python setup.py install --skip-build --optimize=1 --prefix=/usr --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}