summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13b41998e03b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-rainbow-logging-handler
+ pkgdesc = Ultimate Python 3 colorized logger with user-custom color
+ pkgver = 2.2.2
+ pkgrel = 1
+ url = https://github.com/laysakura/rainbow_logging_handler
+ arch = any
+ license = Public Domain
+ makedepends = python-setuptools
+ depends = python
+ provides = python-rainbow-logging-handler-git
+ conflicts = python-rainbow-logging-handler-git
+ source = https://pypi.python.org/packages/source/r/rainbow_logging_handler/rainbow_logging_handler-2.2.2.zip
+ md5sums = e24f2cfa9d7f32dafcc6faffae62ee81
+
+pkgname = python-rainbow-logging-handler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4967b25b87fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: jyantis <yantis@yantis.net>
+
+pkgname=python-rainbow-logging-handler
+pkgver=2.2.2
+pkgrel=1
+pkgdesc="Ultimate Python 3 colorized logger with user-custom color"
+url="https://github.com/laysakura/rainbow_logging_handler"
+depends=('python' )
+makedepends=('python-setuptools' )
+license=('Public Domain')
+arch=('any')
+source=('https://pypi.python.org/packages/source/r/rainbow_logging_handler/rainbow_logging_handler-2.2.2.zip')
+provides=('python-rainbow-logging-handler-git')
+conflicts=('python-rainbow-logging-handler-git')
+md5sums=('e24f2cfa9d7f32dafcc6faffae62ee81')
+
+build() {
+ cd $srcdir/rainbow_logging_handler-2.2.2
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/rainbow_logging_handler-2.2.2
+ python setup.py install --root="$pkgdir" --optimize=1
+}