summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60475c4047c4..54314da5f1f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-ray
pkgdesc = A fast and simple framework for building and running distributed applications.
pkgver = 2.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://ray.io
arch = x86_64
license = Apache-2.0
@@ -25,39 +25,35 @@ pkgbase = python-ray
depends = python-protobuf
depends = python-pyaml
depends = python-redis
- optdepends = python-pandas: for ray[data]
- optdepends = python-pyarrow: for ray[data]
- optdepends = python-fsspec: for ray[data]
+ optdepends = python-pandas: for ray[data, tune, rllib]
+ optdepends = python-pyarrow: for ray[data, tune, rllib]
+ optdepends = python-fsspec: for ray[data, tune, rllib]
optdepends = python-aiohttp: for ray[default, serve]
- optdepends = python-aiosignal: for ray[default, serve]
optdepends = python-aiohttps-cors: for ray[default, serve]
- optdepends = python-aioredis: for ray[default, serve]
optdepends = python-colorful: for ray[default, serve]
- optdepends = python-frozenlist: for ray[default, serve]
optdepends = py-spy: for ray[default, serve]
optdepends = python-requests: for ray[default, serve, tune]
- optdepends = python-gpustat: for ray[default, serve]
optdepends = python-opencensus: for ray[default, serve]
optdepends = python-prometheus_client: for ray[default, serve]
optdepends = python-smart-open: for ray[default, serve]
+ optdepends = python-virtualenv: for ray[default, serve]
optdepends = uvicorn: for ray[serve]
optdepends = python-starlette: for ray[serve]
optdepends = python-fastapi: for ray[serve]
- optdepends = python-pandas: for ray[tune, rllib]
- optdepends = python-tabulate: for ray[tune, rllib]
+ optdepends = python-aiowrlock: for ray[serve]
+ optdepends = python-watchfiles: for ray[serve]
optdepends = python-tensorboardx: for ray[tune, rllib]
- optdepends = python-kubernetes: for ray[k8s]
- optdepends = python-urllib3: for ray[k8s]
- optdepends = python-kopf: for ray[k8s]
optdepends = python-opentelemetry-api: for ray[observability]
optdepends = python-opentelemetry-sdk: for ray[observability]
optdepends = python-opentelemetry-exporter-otlp: for ray[observability]
optdepends = python-dm-tree: for ray[rllib]
- optdepends = python-gym: for ray[rllib]
+ optdepends = python-gymnasium: for ray[rllib]
optdepends = python-lz4: for ray[rllib]
optdepends = python-scikit-image: for ray[rllib]
optdepends = python-pyaml: for ray[rllib]
optdepends = python-scipy: for ray[rllib]
+ optdepends = python-typer: for ray[rllib]
+ optdepends = python-rich: for ray[rllib]
source = python-ray-2.9.0.tar.gz::https://github.com/ray-project/ray/archive/ray-2.9.0.tar.gz
sha256sums = bebe4413dd1a856cd854308d76d14fb412727b6228bfbdea5f3b5a45ef3f5acc
diff --git a/PKGBUILD b/PKGBUILD
index 19657e9890e6..6bb37f8783b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-ray
pkgver=2.9.0
-pkgrel=1
+pkgrel=2
pkgdesc='A fast and simple framework for building and running distributed
applications.'
arch=('x86_64')
@@ -12,39 +12,35 @@ depends=(psmisc python python-attrs python-click python-filelock python-grpcio
python-jsonschema python-msgpack python-numpy python-protobuf
python-pyaml python-redis)
optdepends=(
- 'python-pandas: for ray[data]'
- 'python-pyarrow: for ray[data]'
- 'python-fsspec: for ray[data]'
+ 'python-pandas: for ray[data, tune, rllib]'
+ 'python-pyarrow: for ray[data, tune, rllib]'
+ 'python-fsspec: for ray[data, tune, rllib]'
'python-aiohttp: for ray[default, serve]'
- 'python-aiosignal: for ray[default, serve]'
'python-aiohttps-cors: for ray[default, serve]'
- 'python-aioredis: for ray[default, serve]'
'python-colorful: for ray[default, serve]'
- 'python-frozenlist: for ray[default, serve]'
'py-spy: for ray[default, serve]'
'python-requests: for ray[default, serve, tune]'
- 'python-gpustat: for ray[default, serve]'
'python-opencensus: for ray[default, serve]'
'python-prometheus_client: for ray[default, serve]'
'python-smart-open: for ray[default, serve]'
+ 'python-virtualenv: for ray[default, serve]'
'uvicorn: for ray[serve]'
'python-starlette: for ray[serve]'
'python-fastapi: for ray[serve]'
- 'python-pandas: for ray[tune, rllib]'
- 'python-tabulate: for ray[tune, rllib]'
+ 'python-aiowrlock: for ray[serve]'
+ 'python-watchfiles: for ray[serve]'
'python-tensorboardx: for ray[tune, rllib]'
- 'python-kubernetes: for ray[k8s]'
- 'python-urllib3: for ray[k8s]'
- 'python-kopf: for ray[k8s]'
'python-opentelemetry-api: for ray[observability]'
'python-opentelemetry-sdk: for ray[observability]'
'python-opentelemetry-exporter-otlp: for ray[observability]'
'python-dm-tree: for ray[rllib]'
- 'python-gym: for ray[rllib]'
+ 'python-gymnasium: for ray[rllib]'
'python-lz4: for ray[rllib]'
'python-scikit-image: for ray[rllib]'
'python-pyaml: for ray[rllib]'
'python-scipy: for ray[rllib]'
+ 'python-typer: for ray[rllib]'
+ 'python-rich: for ray[rllib]'
)
makedepends=(python python-build python-installer python-wheel python-setuptools
python-pip cython bazel)