summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ce05a0395a8..c0994980224f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-redis-collections
pkgdesc = Set of basic Python collections backed by Redis.
- pkgver = 0.9.1
+ pkgver = 0.12.0
pkgrel = 1
url = https://github.com/redis-collections/redis-collections
arch = any
license = custom:ISC License (ISCL)
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-pip
depends = python
- source = https://files.pythonhosted.org/packages/source/r/redis-collections/redis-collections-0.9.1.tar.gz
- sha256sums = b018cddabfc9f2bdae63a771607051e5f88857219e421281168a67dfe17aa1d1
+ source = https://files.pythonhosted.org/packages/source/r/redis-collections/redis-collections-0.12.0.tar.gz
+ sha256sums = d7ccc40ddb174eef8343e85b40a33cea4b1faae5e45bdd95cb51bd7aeeba2b6e
pkgname = python-redis-collections
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index a93a04e1cd06..4540bbccf458 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Popolon <popolon@popolon.org>
-pkgbase='python-redis-collections'
-pkgname=('python-redis-collections')
_module='redis-collections'
-pkgver='0.9.1'
+pkgbase="python-${_module}"
+pkgname="python-${_module}"
+pkgver=0.12.0
pkgrel=1
pkgdesc="Set of basic Python collections backed by Redis."
url="https://github.com/redis-collections/redis-collections"
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-pip')
license=('custom:ISC License (ISCL)')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('b018cddabfc9f2bdae63a771607051e5f88857219e421281168a67dfe17aa1d1')
+sha256sums=('d7ccc40ddb174eef8343e85b40a33cea4b1faae5e45bdd95cb51bd7aeeba2b6e')
build() {
cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
depends+=()
cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}