summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 24 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c52bfb8b2a4d..c73920e97962 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
-# Generated by mksrcinfo v8
-# Tue Jan 19 02:21:24 UTC 2016
pkgbase = python-rivescript
pkgdesc = Rendering Intelligence Very Easily
- pkgver = 1.8.1
+ pkgver = 1.15.0
pkgrel = 1
- url = https://pypi.python.org/pypi/rivescript
+ url = https://github.com/aichaos/rivescript-python
arch = any
license = MIT
- depends = python2
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-six
- depends = python2-six
- depends = python-setuptools
- depends = python2-setuptools
- conflicts = python-rivescript-git
- source = https://pypi.python.org/packages/source/r/rivescript/rivescript-1.8.1.tar.gz
- md5sums = 86cba9b7b1cf846d83d61f8ddeafa386
+ source = python-rivescript-1.15.0.tar.gz::https://github.com/aichaos/rivescript-python/archive/refs/tags/v1.15.0.tar.gz
+ sha256sums = d148a9242ea88f2a5f3dd57a663a4ddd56729807ee24edcd37ade7ee690e1bfe
pkgname = python-rivescript
-
diff --git a/PKGBUILD b/PKGBUILD
index bd7b7bcba8d6..6ce72be80119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-# Maintainer: Trevor <assviolat0r at live dot com>
+# Contributor: a821 at mail dot de
+# Contributor: Trevor <assviolat0r at live dot com>
pkgname=python-rivescript
-pkgver=1.8.1
+pkgver=1.15.0
pkgrel=1
pkgdesc="Rendering Intelligence Very Easily"
arch=('any')
license=('MIT')
-depends=('python2' 'python-six' 'python2-six' 'python-setuptools' 'python2-setuptools')
-conflicts=('python-rivescript-git')
-url=('https://pypi.python.org/pypi/rivescript')
-source=('https://pypi.python.org/packages/source/r/rivescript/rivescript-1.8.1.tar.gz')
-md5sums=('86cba9b7b1cf846d83d61f8ddeafa386')
-_distdir="rivescript-1.8.1"
+depends=('python-six')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+url="https://github.com/aichaos/rivescript-python"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('d148a9242ea88f2a5f3dd57a663a4ddd56729807ee24edcd37ade7ee690e1bfe')
-package() {
- cd "$srcdir/$_distdir"
- python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1 || return 1
+build() {
+ cd rivescript-python-$pkgver
+ python -m build --wheel --no-isolation
}
-
-
-
+package() {
+ cd rivescript-python-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}