summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..247fb675ca18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-robopy
+ pkgdesc = A Python 3 implementation of Peter Corke's Robotics Toolbox
+ pkgver = 1.0.8
+ pkgrel = 1
+ url = https://github.com/adityadua24/robopy
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-robopy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bf26686ce97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# PKGBUILD generated by pipman
+# Python package author: Aditya Dua <adityadua24@gmail.com>
+pkgname=python-robopy
+pkgver=1.0.8
+pkgrel=1
+pkgdesc="A Python 3 implementation of Peter Corke's Robotics Toolbox"
+arch=(any)
+url="https://github.com/adityadua24/robopy"
+license=(MIT)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="robopy" robopy==1.0.8
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/robopy/* $pkgdir/"$sitepackages"
+}