summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2069edf7966e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-rocksdb
+ pkgdesc = Python bindings for RocksDB
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/twmht/python-rocksdb
+ arch = any
+ license = BSD
+ license = License
+ makedepends = python
+ makedepends = python-pip
+ depends = rocksdb
+
+pkgname = python-rocksdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22dc447c7a77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+
+pkgname=python-rocksdb
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Python bindings for RocksDB"
+arch=(any)
+url="https://github.com/twmht/python-rocksdb"
+license=(BSD License)
+makedepends=("python" "python-pip")
+depends=("rocksdb")
+build() {
+ pip install --no-deps --target="python-rocksdb" python-rocksdb==$pkgver
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/python-rocksdb/* $pkgdir/"$sitepackages"
+}