summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fef3c470463..66d787bcbba1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
# Generated by mksrcinfo v8
-# Wed Aug 8 13:54:07 UTC 2018
+# Mon Sep 24 08:45:18 UTC 2018
pkgbase = python-slugify
pkgdesc = A Python slugify application that handles unicode
- pkgver = 1.2.5
- pkgrel = 2
+ pkgver = 1.2.6
+ pkgrel = 1
url = https://github.com/un33k/python-slugify
arch = any
license = BSD
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://github.com/un33k/python-slugify/archive/1.2.5.tar.gz
- md5sums = 1d6949c2db9ba0facb42236cc6086099
- sha256sums = 5a819e2519e9c974dbc447d11c3755850262e0bf5563808ccfdd8f4e90468319
+ source = https://github.com/un33k/python-slugify/archive/1.2.6.tar.gz
+ md5sums = 0d2a4d8433a02fa730444bbb7a0caebb
+ sha256sums = a360fd694bf4b78dedb224324e6c3b05682ff1b0354a95b5f78ba1108f3388f8
pkgname = python-slugify
depends = python
depends = python-unidecode>=0.04.16
+ optdepends = python-text-unidecode: text-unidecode support
pkgname = python2-slugify
depends = python2
depends = python2-unidecode>=0.04.16
+ optdepends = python2-text-unidecode: text-unidecode support
diff --git a/PKGBUILD b/PKGBUILD
index 1b84017bfcd7..965f2dde0be7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,27 @@
# Contributor: Andrey Mikhaylenko <neithere at gmail dot com>
pkgname=(python-slugify python2-slugify)
pkgbase=python-slugify
-pkgver=1.2.5
-pkgrel=2
+pkgver=1.2.6
+pkgrel=1
pkgdesc="A Python slugify application that handles unicode"
arch=(any)
url="https://github.com/un33k/python-slugify"
license=('BSD')
makedepends=("python-setuptools" "python2-setuptools")
source=(https://github.com/un33k/python-slugify/archive/${pkgver}.tar.gz)
-md5sums=('1d6949c2db9ba0facb42236cc6086099')
-sha256sums=('5a819e2519e9c974dbc447d11c3755850262e0bf5563808ccfdd8f4e90468319')
+md5sums=('0d2a4d8433a02fa730444bbb7a0caebb')
+sha256sums=('a360fd694bf4b78dedb224324e6c3b05682ff1b0354a95b5f78ba1108f3388f8')
package_python-slugify() {
depends=("python" "python-unidecode>=0.04.16")
+ optdepends=("python-text-unidecode: text-unidecode support")
cd "$srcdir/$pkgbase-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
}
package_python2-slugify() {
depends=("python2" "python2-unidecode>=0.04.16")
+ optdepends=("python2-text-unidecode: text-unidecode support")
cd "$srcdir/$pkgbase-$pkgver"
python2 setup.py install --root="$pkgdir" --optimize=1
mv "$pkgdir/usr/bin/slugify" "$pkgdir/usr/bin/slugify2"