summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0216281dc7f0..77596dbca0ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
# Generated by mksrcinfo v8
-# Fri Jan 4 21:43:37 UTC 2019
+# Mon Mar 11 13:49:36 UTC 2019
pkgbase = python-slugify
pkgdesc = A Python slugify application that handles unicode
- pkgver = 2.0.1
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/un33k/python-slugify
arch = any
license = BSD
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://github.com/un33k/python-slugify/archive/2.0.1.tar.gz
- md5sums = 4d4a370c4d2417bc7ed825ff734af444
- sha256sums = a63e563d35cb6593e7411e18d9dbf90bd48866b45cb97c88c8cf0eaa14b0cca8
+ source = https://github.com/un33k/python-slugify/archive/3.0.0.tar.gz
+ md5sums = 0d812434bbc4a5ec286951ec85ddd3dc
+ sha256sums = 73dc2a8df9e211c89b783388ab59feef852c15755342dcad50c3fee947f9eeeb
pkgname = python-slugify
depends = python
- depends = python-unidecode>=0.04.16
- optdepends = python-text-unidecode: text-unidecode support
+ depends = python-text-unidecode
+ optdepends = python-unidecode: Unidecode support
pkgname = python2-slugify
depends = python2
- depends = python2-unidecode>=0.04.16
- optdepends = python2-text-unidecode: text-unidecode support
+ depends = python2-text-unidecode
+ optdepends = python2-unidecode: Unidecode support
diff --git a/PKGBUILD b/PKGBUILD
index 2e81cdf958cd..677e91f4bc2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Andrey Mikhaylenko <neithere at gmail dot com>
pkgname=(python-slugify python2-slugify)
pkgbase=python-slugify
-pkgver=2.0.1
+pkgver=3.0.0
pkgrel=1
pkgdesc="A Python slugify application that handles unicode"
arch=(any)
@@ -10,19 +10,19 @@ url="https://github.com/un33k/python-slugify"
license=('BSD')
makedepends=("python-setuptools" "python2-setuptools")
source=(https://github.com/un33k/python-slugify/archive/${pkgver}.tar.gz)
-md5sums=('4d4a370c4d2417bc7ed825ff734af444')
-sha256sums=('a63e563d35cb6593e7411e18d9dbf90bd48866b45cb97c88c8cf0eaa14b0cca8')
+md5sums=('0d812434bbc4a5ec286951ec85ddd3dc')
+sha256sums=('73dc2a8df9e211c89b783388ab59feef852c15755342dcad50c3fee947f9eeeb')
package_python-slugify() {
- depends=("python" "python-unidecode>=0.04.16")
- optdepends=("python-text-unidecode: text-unidecode support")
+ depends=("python" "python-text-unidecode")
+ optdepends=("python-unidecode: Unidecode support")
cd "$srcdir/$pkgbase-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
}
package_python2-slugify() {
- depends=("python2" "python2-unidecode>=0.04.16")
- optdepends=("python2-text-unidecode: text-unidecode support")
+ depends=("python2" "python2-text-unidecode")
+ optdepends=("python2-unidecode: Unidecode support")
cd "$srcdir/$pkgbase-$pkgver"
python2 setup.py install --root="$pkgdir" --optimize=1
mv "$pkgdir/usr/bin/slugify" "$pkgdir/usr/bin/slugify2"