summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..589a412dde20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-spectate
+ pkgdesc = Observe the evolution of mutable data types like lists, dicts, and sets.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/rmorshea/spectate
+ arch = any
+ license = MIT
+ depends = python
+ noextract = spectate-1.0.1-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/s/spectate/spectate-1.0.1-py2.py3-none-any.whl
+ sha256sums = c4585194c238979f953fbf2ecf9f94c84d9d0a929432c7104e39984f52c9e718
+
+pkgname = python-spectate
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..910c2436b01b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.pkg.*
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dcf8e33ce566
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=spectate
+pkgname=python-$_name
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Observe the evolution of mutable data types like lists, dicts, and sets.'
+arch=(any)
+url="https://github.com/rmorshea/$_name"
+license=(MIT)
+depends=(python)
+_wheel="${_name/-/_}-$pkgver-py2.py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/$_name/$_wheel")
+sha256sums=('c4585194c238979f953fbf2ecf9f94c84d9d0a929432c7104e39984f52c9e718')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+}