summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..525664053c63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-sphinx-renku-theme
+ pkgdesc = Sphinx theme for Renku documentation
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/SwissDataScienceCenter/renku-sphinx-theme
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ source = https://github.com/SwissDataScienceCenter/renku-sphinx-theme/archive/refs/tags/v0.2.2.tar.gz
+ sha256sums = a02e96e4b15fb3100d5d0d549795c47e35c66219a6279723848212fe2a206e3b
+
+pkgname = python-sphinx-renku-theme
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba93b9e5d6c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=('python-sphinx-renku-theme')
+pkgver=0.2.2
+pkgrel=1
+pkgdesc='Sphinx theme for Renku documentation'
+arch=('any')
+url='https://github.com/SwissDataScienceCenter/renku-sphinx-theme'
+license=('Apache')
+makedepends=('python-setuptools')
+source=("https://github.com/SwissDataScienceCenter/renku-sphinx-theme/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('a02e96e4b15fb3100d5d0d549795c47e35c66219a6279723848212fe2a206e3b')
+
+build() {
+ cd $srcdir/renku-sphinx-theme-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd renku-sphinx-theme-$pkgver
+ python setup.py install --root $pkgdir --optimize=1
+}