summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..324478e669fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-sphinx-testing
+ pkgdesc = Testing utility classes and functions for Sphinx extensions
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/sphinx-testing/
+ arch = any
+ license = BSD
+ makedepends = python-pip
+ depends = python-sphinx
+ depends = python-six
+ source = https://pypi.python.org/packages/source/s/sphinx-testing/sphinx-testing-0.7.1.tar.gz
+ md5sums = 0292c02299c00c1bf33c86ac50feaa79
+
+pkgname = python-sphinx-testing
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..207108c9c010
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id$
+# Maintainer: vri <t.j.a.devries(at)gmail(dot)com>
+
+# for customization
+_pre=python-
+_pkgname=sphinx-testing
+_ext=
+_basedir=/usr
+
+pkgname=${_pre}${_pkgname}${_ext}
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Testing utility classes and functions for Sphinx extensions"
+arch=(any)
+url="https://pypi.python.org/pypi/sphinx-testing/"
+license=('BSD')
+depends=('python-sphinx' 'python-six')
+#optdepends=()
+makedepends=('python-pip')
+#options=()
+source=(
+ https://pypi.python.org/packages/source/s/${_pkgname}/${_pkgname}-${pkgver}.tar.gz
+ )
+md5sums=(
+ '0292c02299c00c1bf33c86ac50feaa79'
+ )
+
+build() {
+ msg "Nothing to do..."
+}
+
+package() {
+ cd "${srcdir}"
+ /usr/bin/pip install --root="$pkgdir/" "${_pkgname}"
+ install -Dm644 ${srcdir}/${_pkgname}-${pkgver}/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+