summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD11
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5418ffcc4eea..b608f65b07c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sport-activities-features
pkgdesc = Minimalistic toolbox for extracting features from sports activity files written in Python
- pkgver = 0.3.18
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/firefly-cpp/sport-activities-features
arch = any
@@ -11,12 +11,12 @@ pkgbase = python-sport-activities-features
makedepends = python-poetry-core
depends = python-geopy
depends = python-overpy
- depends = python-gpxpy
depends = python-geotiler
depends = python-tcxreader
depends = python-niaaml
depends = python-tcx2gpx
- source = sport-activities-features-0.3.18.tar.gz::https://github.com/firefly-cpp/sport-activities-features/archive/0.3.18.tar.gz
- sha512sums = c6be1867b8c9a83ec501ad76905bb3c74e5ad802f10f8003b66192f7faddf1ed21b492650acce620db059afc55f0f97eaef12fd785fc7c5cd0bab97b3a6ea3a7
+ depends = python-gpxpy
+ source = sport-activities-features-0.4.0.tar.gz::https://github.com/firefly-cpp/sport-activities-features/archive/0.4.0.tar.gz
+ sha512sums = 8766f1b5f8c3daba044aab26d8369a4342a80bb58a3abbf04a98ab846bebcef8e90d96b070f8f894a3af8796e246e7a4ce43a3a680c0c4d22cba2104fba5073e
pkgname = python-sport-activities-features
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..56b8ba3195da
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[python-sport-activities-features]
+source = "github"
+github = "firefly-cpp/sport-activities-features"
+use_latest_release = "true" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 4a5bcf8b1d4b..7eb2c05cf473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_base=sport-activities-features
pkgname=python-${_base}
pkgdesc="Minimalistic toolbox for extracting features from sports activity files written in Python"
-pkgver=0.3.18
+pkgver=0.4.0
pkgrel=1
arch=(any)
url="https://github.com/firefly-cpp/${_base}"
license=(MIT)
-depends=(python-geopy python-overpy python-gpxpy python-geotiler python-tcxreader
- python-niaaml python-tcx2gpx)
+depends=(python-geopy python-overpy python-geotiler python-tcxreader
+ python-niaaml python-tcx2gpx python-gpxpy)
makedepends=(python-build python-installer python-poetry-core)
checkdepends=(python-pytest)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
-sha512sums=('c6be1867b8c9a83ec501ad76905bb3c74e5ad802f10f8003b66192f7faddf1ed21b492650acce620db059afc55f0f97eaef12fd785fc7c5cd0bab97b3a6ea3a7')
+sha512sums=('8766f1b5f8c3daba044aab26d8369a4342a80bb58a3abbf04a98ab846bebcef8e90d96b070f8f894a3af8796e246e7a4ce43a3a680c0c4d22cba2104fba5073e')
build() {
cd ${_base}-${pkgver}
@@ -21,8 +21,7 @@ build() {
check() {
cd ${_base}-${pkgver}
- python -m pytest \
- -k 'not load_pipeline'
+ python -m pytest -k 'not load_pipeline'
}
package() {