summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0126d3237cc..27630b4e2be3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = python-ssh2
pkgdesc = Python bindings for libssh2
pkgver = 1.0.0
pkgrel = 1
- url = https://github.com/ParallelSSH/ssh2-python/
+ url = https://github.com/parallel-ssh/ssh2-python/
arch = x86_64
license = GPL
checkdepends = openssh
@@ -10,9 +10,7 @@ pkgbase = python-ssh2
makedepends = python-setuptools
makedepends = cython
depends = libssh2
- source = python-ssh2-1.0.0.tar.gz::https://github.com/ParallelSSH/ssh2-python/archive/1.0.0.tar.gz
- source = fix-tests.patch
- sha256sums = 70c6b6efd8ca9f8de9c2d77e7cb1d5859542588347ea426d6822b0ffd9889af3
- sha256sums = b328ec97238be0fab6171108666c18f7818de2dea247857851b2356303d65e19
+ source = git+https://github.com/parallel-ssh/ssh2-python.git
+ sha256sums = SKIP
pkgname = python-ssh2
diff --git a/PKGBUILD b/PKGBUILD
index 873c048719b0..b6e0d239c050 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,34 +4,27 @@ _pkgname='ssh2-python'
pkgver=1.0.0
pkgrel=1
pkgdesc="Python bindings for libssh2"
-url="https://github.com/ParallelSSH/ssh2-python/"
+url="https://github.com/parallel-ssh/ssh2-python/"
depends=('libssh2')
makedepends=('python-setuptools' 'cython')
checkdepends=('openssh' 'python-pytest')
license=('GPL')
arch=('x86_64')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ParallelSSH/$_pkgname/archive/$pkgver.tar.gz"
- "fix-tests.patch")
-sha256sums=('70c6b6efd8ca9f8de9c2d77e7cb1d5859542588347ea426d6822b0ffd9889af3'
- 'b328ec97238be0fab6171108666c18f7818de2dea247857851b2356303d65e19')
-
-prepare() {
- cd "${_pkgname}-${pkgver}"
- patch -p1 -i ../fix-tests.patch
-}
+source=("git+https://github.com/parallel-ssh/ssh2-python.git")
+sha256sums=('SKIP')
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}"
SYSTEM_LIBSSH2=1 python setup.py build
}
package() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}"
SYSTEM_LIBSSH2=1 python setup.py install --skip-build --root="${pkgdir}" --optimize=1
}
check() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}"
SYSTEM_LIBSSH2=1 python setup.py build_ext --inplace
pytest tests
}