summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2370b92035c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-sxdes
+ pkgdesc = run the sep code on images with DES settings
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/esheldon/sxdes
+ arch = x86_64
+ license = GPL3
+ checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python-sep
+ source = sxdes-0.3.0.tar.gz::https://github.com/esheldon/sxdes/archive/0.3.0.tar.gz
+ sha512sums = f6ebb957c688f738762612fc0152b51d0fced4564b486d89aea44ba48ff6de06b0506809e31a2eb669067a3a41adc810646983ca9ddabc2d28a65d65584b3e27
+
+pkgname = python-sxdes
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02c7a9f46f91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=sxdes
+pkgname=python-${_base}
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="run the sep code on images with DES settings"
+arch=(x86_64)
+url="https://github.com/esheldon/${_base}"
+license=(GPL3)
+depends=(python-sep)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+checkdepends=(python-pytest)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('f6ebb957c688f738762612fc0152b51d0fced4564b486d89aea44ba48ff6de06b0506809e31a2eb669067a3a41adc810646983ca9ddabc2d28a65d65584b3e27')
+
+build() {
+ cd ${_base}-${pkgver}
+ python setup.py build_ext --inplace
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}