summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
2 files changed, 41 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b857eec4933..00880ee676f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = python-tblfaker
pkgdesc = Python library to generate fake tabular data
- pkgver = 0.2.3
- pkgrel = 2
+ pkgver = 0.2.4
+ pkgrel = 1
url = https://github.com/thombashi/tblfaker
arch = any
license = MIT
makedepends = python-setuptools
depends = python-faker
- depends = python-tabledata
- source = https://files.pythonhosted.org/packages/source/t/tblfaker/tblfaker-0.2.3.tar.gz
- sha256sums = 48e3ff4f2c58d7d3c51ca61a2dcf807c394f54b1cac443d15241127a6169b198
+ depends = python-tabledata>=1.1.1
+ depends = python-tabledata<2
+ source = python-tblfaker-0.2.4.tar.gz::https://files.pythonhosted.org/packages/source/t/tblfaker/tblfaker-0.2.4.tar.gz
+ source = python-tblfaker-0.2.4.tar.gz.asc::https://files.pythonhosted.org/packages/source/t/tblfaker/tblfaker-0.2.4.tar.gz.asc
+ validpgpkeys = BCF9203E5E80B5607EAE6FDD98CDA9A5F0BFC367
+ sha256sums = 3da3b13cfee632a20608b5854c9a40665c0e23d47db59b1f88ea0c3a0beb6fe2
+ sha256sums = SKIP
pkgname = python-tblfaker
-
diff --git a/PKGBUILD b/PKGBUILD
index a3e3c72e0a08..fdad2f9ba1cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,47 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
-_pkgname='tblfaker'
-pkgname="python-${_pkgname}"
-pkgver=0.2.3
-pkgrel=2
+pkgname=python-tblfaker
+pkgver=0.2.4
+pkgrel=1
pkgdesc='Python library to generate fake tabular data'
arch=('any')
url='https://github.com/thombashi/tblfaker'
-_url_pypi='https://pypi.org/project/tblfaker'
license=('MIT')
-depends=('python-faker' 'python-tabledata')
+depends=(
+ 'python-faker'
+ 'python-tabledata>=1.1.1'
+ 'python-tabledata<2')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('48e3ff4f2c58d7d3c51ca61a2dcf807c394f54b1cac443d15241127a6169b198')
+# checkdepends=(
+# 'python-pytablewriter>=0.46'
+# 'python-pytest>=6.0.1'
+# 'python-pytest-runner'
+# 'python-pytest-discord>=0.0.5'
+# 'python-pytest-md-report>=0.1'
+# 'python-dateutil'
+# 'python-pytz')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/t/tblfaker/tblfaker-$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/t/tblfaker/tblfaker-$pkgver.tar.gz.asc")
+sha256sums=('3da3b13cfee632a20608b5854c9a40665c0e23d47db59b1f88ea0c3a0beb6fe2'
+ 'SKIP')
+validpgpkeys=('BCF9203E5E80B5607EAE6FDD98CDA9A5F0BFC367')
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "tblfaker-$pkgver"
python setup.py build
}
+# check() {
+# cd "tblfaker-$pkgver"
+# python setup.py pytest
+# }
+
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd "tblfaker-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 'README.rst' -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 'LICENSE' -t "$pkgdir/usr/share/licenses/$pkgname"
}
# vim: ts=2 sw=2 et: