summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d86f85e0dd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-tellcore-py-git
+ pkgdesc = Python wrapper for Telldus' home automation library.
+ pkgver = 20130810
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/tellcore-py
+ arch = any
+ groups = devel
+ license = GPL3
+ makedepends = python
+ makedepends = git
+ depends = python
+ conflicts = python-tellcore-py
+ options = !emptydirs
+
+pkgname = python-tellcore-py-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41837f1f9560
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Olivier Biesmans <o.aurlinux@biesmans.fr>
+
+pkgname=python-tellcore-py-git
+pkgver=20130810
+pkgrel=1
+pkgdesc="Python wrapper for Telldus' home automation library."
+arch=('any')
+url="https://pypi.python.org/pypi/tellcore-py"
+license=('GPL3')
+groups=('devel')
+depends=('python')
+makedepends=('python' 'git')
+provides=()
+conflicts=('python-tellcore-py')
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=()
+_gitroot='https://github.com/erijo/tellcore-py.git'
+_gitname=tellcore-py
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: