summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f99d4b48e06a..741dc43d2ca0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = python-tensorly
pkgdesc = Simple and Fast Tensor Learning in Python
pkgver = 0.7.0
- pkgrel = 1
+ pkgrel = 3
url = https://tensorly.org/stable/home.html
changelog = python-tensorly.changelog
arch = any
license = BSD
checkdepends = python-pytest
- checkdepends = python-numpy
checkdepends = python-pytorch
checkdepends = python-tensorflow
makedepends = python-setuptools
depends = python
- optdepends = python-numpy
+ depends = python-numpy
+ depends = python-scipy
optdepends = python-pytorch
optdepends = python-tensorflow
optdepends = mxnet
diff --git a/PKGBUILD b/PKGBUILD
index 512d4e101578..3310dfcaf5c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,20 @@
pkgname='python-tensorly'
pkgver=0.7.0
-pkgrel=1
+pkgrel=3
pkgdesc="Simple and Fast Tensor Learning in Python"
arch=('any')
url="https://tensorly.org/stable/home.html"
license=('BSD')
depends=(
python
+ python-numpy
+ python-scipy
)
makedepends=(
python-setuptools
)
optdepends=(
- python-numpy
python-pytorch
python-tensorflow
)
@@ -50,7 +51,7 @@ check() {
# So many flaky tests...
# https://github.com/tensorly/tensorly/issues/310
TENSORLY_BACKEND=$backend pytest -v tensorly \
- -k 'not test_svd and not test_active_set_nnls and not test_tr_tensor and not test_hals_nnls and not validate_tucker_rank and not test_parafac'
+ -k 'not test_svd and not test_tr_tensor and not validate_tucker_rank and not test_parafac'
done
}