summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1505f8b5bf5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-textwrap3
+ pkgdesc = textwrap from Python 3.6 backport (plus a few tweaks)
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://github.com/jonathaneunice/textwrap3
+ arch = any
+ license = Python
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/t/textwrap3/textwrap3-0.9.2.zip
+ md5sums = fb3ce1d1b93adecd367a0f6c39f98306
+
+pkgname = python-textwrap3
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7c2c263800d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ben Oliver <ben@bfoliver.com>
+
+pkgbase='python-textwrap3'
+pkgname=('python-textwrap3')
+_module='textwrap3'
+pkgver='0.9.2'
+pkgrel=1
+pkgdesc="textwrap from Python 3.6 backport (plus a few tweaks)"
+url="https://github.com/jonathaneunice/textwrap3"
+depends=('python')
+makedepends=('python-setuptools')
+license=('Python')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.zip")
+md5sums=('fb3ce1d1b93adecd367a0f6c39f98306')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}