summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aff65a8b2f8b..f35e12b9df49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: David McInnis<anntzer dot lee at gmail dot com>
+# Maintainer: David McInnis<davidm@eagles.ewu.edu>
pkgbase="python-theano"
pkgname=("python-theano" "python2-theano")
_pkgname="Theano"
pkgver="0.7.0"
-pkgrel="1"
+pkgrel="2"
pkgdesc='Definition and optimized evaluation of mathematical expressions on Numpy arrays.'
arch=('any')
url='http://www.deeplearning.net/software/theano/'
license=('BSD')
-depends=('python' 'python-numpy'
- 'python2' 'python2-numpy')
+depends=('python' 'python-numpy'
+ 'python2' 'python2-numpy')
makedepends=('python-distribute' 'python2-distribute')
checkdepends=('python-nose' 'python2-nose')
optdepends=('python-sympy' 'python-pycuda' 'python-pydot'
@@ -41,17 +41,19 @@ build() {
cp -f build/scripts-3.4/* bin/
}
-check() {
- msg "Checking Python 2"
- cd "$srcdir/${_pkgname}-${pkgver}-py2"/build/lib/theano/
- ../../scripts-2.7/theano-nose -v
-
-
- msg "Checking Python 3"
- cd "$srcdir/${_pkgname}-${pkgver}"/build/lib/theano/
- ../../scripts-3.4/theano-nose -v
-
-}
+# Check always fails on non-64 bit platforms. Check frequently fails if optional dependencies are present
+# Even if check succeeds it takes hours to complete
+#
+#check() {
+# msg "Checking Python 2"
+# cd "$srcdir/${_pkgname}-${pkgver}-py2"/build/lib/theano/
+# ../../scripts-2.7/theano-nose -v
+#
+#
+# msg "Checking Python 3"
+# cd "$srcdir/${_pkgname}-${pkgver}"/build/lib/theano/
+# ../../scripts-3.4/theano-nose -v
+#}
package_python2-theano() {
depends=('python2' 'python2-numpy')