summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..089be1754812
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-unireedsolomon-git
+ pkgdesc = Documented Universal Errors-and-erasures Reed Solomon Codec written in pure Python
+ pkgver = f375f61
+ pkgrel = 1
+ url = https://github.com/lrq3000/unireedsolomon
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ optdepends = cython
+ source = git+https://github.com/lrq3000/unireedsolomon.git
+ sha256sums = SKIP
+
+pkgname = python-unireedsolomon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38b64deae010
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Edwin Peters <slimed13 at hotmail dot com>
+
+pkgname=python-unireedsolomon-git
+pkgver=f375f61
+pkgrel=1
+pkgdesc="Documented Universal Errors-and-erasures Reed Solomon Codec written in pure Python"
+arch=('any')
+url="https://github.com/lrq3000/unireedsolomon"
+license=('MIT')
+depends=('python' )
+optdepends=('cython' )
+makedepends=('python-setuptools' 'git')
+source=(git+https://github.com/lrq3000/unireedsolomon.git)
+sha256sums=(SKIP)
+
+package() {
+ cd ${srcdir}/unireedsolomon
+
+ # ignores any LDFLAGS set in makepkg.conf
+ unset LDFLAGS
+
+ python ./setup.py install --root=${pkgdir}
+
+}
+