summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2d56c4fcf5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-urwid-ueberzogen
+ pkgdesc = Some widgets which extend urwid with the possibility to use ueberzug.
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/d0c-s4vage/lookatme.contrib.image_ueberzug
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-ueberzug
+ depends = python-urwid
+ source = urwid-ueberzogen-0.0.4.tar.gz::https://github.com/seebye/urwid-ueberzogen/archive/refs/tags/0.0.4.tar.gz
+ md5sums = 85336dc1398186cc9e24222c8a79714b
+
+pkgname = python-urwid-ueberzogen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e4e99ea6f28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+#Maintainer: KarlWithK < jocelinc60 at outlook d@t com >
+pkgname=python-urwid-ueberzogen
+_pkgname=urwid-ueberzogen
+pkgver=0.0.4
+pkgrel=1
+pkgdesc='Some widgets which extend urwid with the possibility to use ueberzug.'
+arch=('any')
+url="https://github.com/seebye/urwid-ueberzogen"
+license=('GPL3')
+depends=('python-ueberzug' 'python-urwid')
+makedepends=('python-setuptools')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/seebye/${_pkgname}/archive/refs/tags/${pkgver}.tar.gz")
+md5sums=('85336dc1398186cc9e24222c8a79714b')
+
+build() {
+ cd "$srcdir/$_pkgname-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-${pkgver}"
+ python setup.py install --skip-build --optimize=1 --root="$pkgdir/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: