summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8786ce8f1051..6956e562d1e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-varname-git
pkgdesc = A Python library to retrieve variable names from functions or classes -- git version
pkgver = 0.13.0.r0.gea1ec82
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pwwang/python-varname
arch = any
license = MIT
@@ -11,11 +11,10 @@ pkgbase = python-varname-git
makedepends = python-installer
makedepends = python-wheel
makedepends = python-poetry
- makedepends = python-virtualenv
- makedepends = python-cachecontrol
- makedepends = python-poetry-plugin-export
- makedepends = python-jsonschema
depends = python
+ depends = python-executing
+ optdepends = python-asttokens
+ optdepends = python-pure-eval
source = git+https://github.com/pwwang/python-varname.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 247acbd98544..20ac049768cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
_pkgname=python-varname
pkgname=${_pkgname}-git
pkgver=0.13.0.r0.gea1ec82
-pkgrel=2
+pkgrel=3
pkgdesc="A Python library to retrieve variable names from functions or classes -- git version"
arch=('any')
url="https://github.com/pwwang/${_pkgname}"
license=('MIT')
-depends=('python')
-makedepends=('git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel' 'python-poetry' 'python-virtualenv' 'python-cachecontrol' 'python-poetry-plugin-export' 'python-jsonschema')
+depends=('python' 'python-executing')
+optdepends=('python-asttokens' 'python-pure-eval')
+makedepends=('git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel' 'python-poetry')
source=("git+${url}.git")
sha512sums=('SKIP')
@@ -24,7 +25,8 @@ prepare() {
build() {
cd "${_pkgname}"
- python -m build --wheel --no-isolation
+ ## skip dependency check because of pinned deps
+ python -m build --wheel --no-isolation --skip-dependency-check
}
package() {