summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb59907bd207
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-vkbeautify
+ pkgdesc = python plugin to pretty-print or minify text in XML, JSON and CSS formats
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/willthames/ansible-lint
+ arch = any
+ license = MIT
+ depends = python3
+ source = python-vkbeautify-0.3.0.tar.gz::https://files.pythonhosted.org/packages/source/v/vkbeautify/vkbeautify-0.3.0.tar.gz
+ md5sums = bab6bceaffaadb43e14170b27969945f
+
+pkgname = python-vkbeautify
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fc736eb5f24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_pkgname=vkbeautify
+pkgname=python-${_pkgname}
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="python plugin to pretty-print or minify text in XML, JSON and CSS formats"
+arch=('any')
+url="https://github.com/willthames/ansible-lint"
+license=('MIT')
+depends=('python3')
+#makedepends=('python-distutils')
+source=(${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+md5sums=('bab6bceaffaadb43e14170b27969945f')
+
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ export PYTHONHASHSEED=0
+ python setup.py install --optimize=1 --root="${pkgdir}"
+}