summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD81
2 files changed, 68 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c70b24c3aed..b4740ff9938d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,29 @@
pkgbase = python-whois
pkgdesc = Whois querying and parsing of domain registration information
- pkgver = 0.7.3
+ pkgver = 0.8.0
pkgrel = 1
url = https://bitbucket.org/richardpenman/pywhois
- arch = i686
arch = x86_64
+ arch = i686
+ arch = pentium4
+ arch = aarch64
+ arch = armv7h
license = CUSTOM
makedepends = python
- makedepends = python2
makedepends = python-setuptools
makedepends = python2-setuptools
- depends = python
depends = python2
- source = https://files.pythonhosted.org/packages/source/p/python-whois/python-whois-0.7.3.tar.gz
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/python-whois/python-whois-0.8.0.tar.gz
source = LICENSE
- source = python-whois-0.7.3.tar.gz.sig
- source = LICENSE.sig
validpgpkeys = 748231EBCBD808A14F5E85D28C004C2F93481F6B
- sha512sums = 59ef578d7611f8925449dd837c8f77982eeffb2e5454ed2f893596dfc73dd984d52d1e5e557d3424bca136b40ff14e720e55feb424692c448e94fee6cd65cdc2
+ sha512sums = 17c7d5aae8f4a3b460222137c944bda60d42692a01983e70edf316ea16e7210922cb8baf6cc94d912716582a880df80a4c9d2a83aa88db73a9011b2b3117273c
sha512sums = 8cf4065e880c751354fffe41f513b95c6bad6bd28033d7a660bd52636cae0c313f9b60f4c53234320699fc0b44d9e4b42bb06f543733b41e0de07a68068099d1
- sha512sums = SKIP
- sha512sums = SKIP
-
-pkgname = python-whois
- depends = python
- depends = python-future
pkgname = python2-whois
depends = python2
depends = python2-futures
+pkgname = python-whois
+ depends = python
+ depends = python-future
diff --git a/PKGBUILD b/PKGBUILD
index 89ca1010a9bd..6d1e9eb51719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,74 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
# Maintainer: brent s. <bts[at]square-r00t[dot]net>
-validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net
-pkgname=('python-whois' 'python2-whois')
-pkgver=0.7.3
+
+_py=python2
+_pkg=whois
+_name="py${_pkg}"
+_pkgname="python-${_pkg}"
+pkgbase="${_pkgname}"
+pkgname=(
+ "${_py}-${_pkg}"
+ "python-${_pkg}")
+pkgver=0.8.0
pkgrel=1
pkgdesc="Whois querying and parsing of domain registration information"
-arch=( 'i686' 'x86_64' )
-url="https://bitbucket.org/richardpenman/pywhois"
+arch=(
+ x86_64
+ i686
+ pentium4
+ aarch64
+ armv7h
+)
+url="https://bitbucket.org/richardpenman/${_name}"
license=( 'CUSTOM' )
-depends=( 'python' 'python2' )
-makedepends=( 'python' 'python2' 'python-setuptools' 'python2-setuptools' )
-_pkgname=python-whois
+depends=(
+ "${_py}"
+ "python"
+)
+makedepends=(
+ "python"
+ "python-setuptools"
+ "${_py}-setuptools"
+)
install=
changelog=
noextract=()
-source=("https://files.pythonhosted.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
- "LICENSE"
- "${_pkgname}-${pkgver}.tar.gz.sig"
- "LICENSE.sig")
-sha512sums=('59ef578d7611f8925449dd837c8f77982eeffb2e5454ed2f893596dfc73dd984d52d1e5e557d3424bca136b40ff14e720e55feb424692c448e94fee6cd65cdc2'
- '8cf4065e880c751354fffe41f513b95c6bad6bd28033d7a660bd52636cae0c313f9b60f4c53234320699fc0b44d9e4b42bb06f543733b41e0de07a68068099d1'
- 'SKIP'
- 'SKIP')
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+_pypi_repo="https://files.pythonhosted.org/packages/source"
+source=(
+ "${_pypi_repo}/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "LICENSE"
+)
+sha512sums=(
+ '17c7d5aae8f4a3b460222137c944bda60d42692a01983e70edf316ea16e7210922cb8baf6cc94d912716582a880df80a4c9d2a83aa88db73a9011b2b3117273c'
+ '8cf4065e880c751354fffe41f513b95c6bad6bd28033d7a660bd52636cae0c313f9b60f4c53234320699fc0b44d9e4b42bb06f543733b41e0de07a68068099d1'
+)
package_python-whois() {
- depends=('python' 'python-future')
-
+ depends=(
+ 'python'
+ 'python-future'
+)
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
- install -Dm 0644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="${pkgdir}" \
+ --optimize=1
+ install -Dm 0644 ${srcdir}/LICENSE \
+ "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
package_python2-whois() {
- depends=('python2' 'python2-futures')
-
+ local _site_packages
+ _site_packages="$(python2 -c 'import site; print site.getsitepackages()[0]')"
+ depends=(
+ "${_py}"
+ "${_py}-futures"
+ )
cd "${srcdir}/${_pkgname}-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
- install -Dm 0644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ PYTHONPATH="${_site_packages}" \
+ "${_py}" setup.py install --root="${pkgdir}" \
+ --optimize=1
+ install -Dm 0644 ${srcdir}/LICENSE \
+ "${pkgdir}/usr/share/licenses/${_py}-${_pkg}/LICENSE"
}