summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD50
-rw-r--r--wordcloud.patch13
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74ac6bb57fd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Tue May 10 00:49:21 UTC 2016
+pkgbase = python-word-cloud-git
+ pkgdesc = A little word cloud generator in Python 2
+ pkgver = 1.2.1.r1.g00488b8
+ pkgrel = 1
+ url = https://github.com/amueller/word_cloud
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = cython
+ depends = python-pillow
+ depends = python-numpy
+ depends = ttf-droid
+ provides = python-word_cloud
+ conflicts = python-word_cloud
+ source = git://github.com/amueller/word_cloud.git
+ source = wordcloud.patch
+ sha256sums = SKIP
+ sha256sums = 0d3379d5a8c4481c2a3deaa8ab809c1817fa9a5e6178f7a55773ef45f46c8f10
+
+pkgname = python-word-cloud-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a90e3355d235
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.pkg.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09b0d075336f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: ShadowKyogre <shadowkyogre.public@gmail.com>
+
+pkgname=python-word-cloud-git
+pkgver=1.2.1.r1.g00488b8
+pkgrel=1
+pkgdesc='A little word cloud generator in Python 2'
+arch=('any')
+arch=('i686' 'x86_64')
+url='https://github.com/amueller/word_cloud'
+license=('MIT')
+depends=('python' 'cython' 'python-pillow' 'python-numpy' 'ttf-droid')
+source=('git://github.com/amueller/word_cloud.git' 'wordcloud.patch')
+sha256sums=('SKIP' '0d3379d5a8c4481c2a3deaa8ab809c1817fa9a5e6178f7a55773ef45f46c8f10')
+makedepends=('git' 'python-setuptools')
+provides=('python-word_cloud')
+conflicts=('python-word_cloud')
+
+pkgver() {
+ cd word_cloud
+ set -o pipefail
+ _gitversion=$( git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
+ echo "$_gitversion"
+}
+
+build() {
+ # patch to fix font patch for Arch Linux
+ #patch word_cloud/wordcloud/wordcloud.py < wordcloud.patch
+
+ cd word_cloud
+
+ python setup.py build
+}
+
+package() {
+ cd word_cloud
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/wordcloud.patch b/wordcloud.patch
new file mode 100644
index 000000000000..81b647a7afdf
--- /dev/null
+++ b/wordcloud.patch
@@ -0,0 +1,13 @@
+--- wordcloud.original 2015-01-08 08:04:20.760754809 -0800
++++ wordcloud.modified 2015-01-08 08:14:58.750537478 -0800
+@@ -18,7 +18,9 @@
+
+ item1 = itemgetter(1)
+
+-FONT_PATH = os.environ.get("FONT_PATH", "/usr/share/fonts/truetype/droid/DroidSansMono.ttf")
++# Patch to work on Arch Linux
++FONT_PATH = "/usr/share/fonts/TTF/DroidSansMono.ttf"
++# FONT_PATH = os.environ.get("FONT_PATH", "/usr/share/fonts/truetype/droid/DroidSansMono.ttf")
+ STOPWORDS = set([x.strip() for x in open(os.path.join(os.path.dirname(__file__),
+ 'stopwords')).read().split('\n')])
+