summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD12
3 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 255644c58292..258d7b04a666 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-wsgi-intercept
pkgdesc = Intercept socket connection to wsgi applications for testing
pkgver = 1.13.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/cdent/wsgi-intercept
arch = any
license = MIT
@@ -19,8 +19,7 @@ pkgbase = python-wsgi-intercept
optdepends = python-httplib2: for intercepting requests of python-httplib2
optdepends = python-requests: for intercepting requests of python-requests
optdepends = python-urllib3: for intercepting requests of python-urllib3
- provides = python-wsgi-intercept
- source = wsgi-intercept-1.13.0.tar.gz::https://github.com/cdent/wsgi-intercept/archive/refs/tags/v1.13.0.tar.gz
- b2sums = 522b8149c68ac47c5074714731ac758b67d90199b42b2a30629724c097093b35bb29e34ddc20906141ed0682863910297d88374128544a8f268b347483c7761c
+ source = wsgi-intercept-1.13.0.tar.gz::https://api.github.com/repos/cdent/wsgi-intercept/tarball/refs/tags/v1.13.0
+ b2sums = 57ed44e6dd1bdf70193a4920da15b8e0dd2c5dd41a61efedf6f9aaf4778114519c7766dec9a3f42690dce4be061785fd62c1f1e847d9d6f034dfe1846b454f19
pkgname = python-wsgi-intercept
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index f040a97eb0a8..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-*
-!.gitignore
-!PKGBUILD
-!*.install
-!.SRCINFO
-!keys/
-!CHANGELOG.*
diff --git a/PKGBUILD b/PKGBUILD
index 71af5444a139..87bf7ed9566b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=python-wsgi-intercept
_name=${pkgname#python-}
pkgver=1.13.0
-pkgrel=2
+pkgrel=3
pkgdesc="Intercept socket connection to wsgi applications for testing"
arch=(any)
url="https://github.com/cdent/wsgi-intercept"
@@ -25,9 +25,12 @@ checkdepends=('python-httplib2'
optdepends=('python-httplib2: for intercepting requests of python-httplib2'
'python-requests: for intercepting requests of python-requests'
'python-urllib3: for intercepting requests of python-urllib3')
-provides=("$pkgname")
-source=("$_name-$pkgver.tar.gz::https://github.com/cdent/$_name/archive/refs/tags/v$pkgver.tar.gz")
-b2sums=('522b8149c68ac47c5074714731ac758b67d90199b42b2a30629724c097093b35bb29e34ddc20906141ed0682863910297d88374128544a8f268b347483c7761c')
+source=("$_name-$pkgver.tar.gz::https://api.github.com/repos/cdent/$_name/tarball/refs/tags/v$pkgver")
+b2sums=('57ed44e6dd1bdf70193a4920da15b8e0dd2c5dd41a61efedf6f9aaf4778114519c7766dec9a3f42690dce4be061785fd62c1f1e847d9d6f034dfe1846b454f19')
+
+prepare() {
+ tar zxvf "$_name-$pkgver.tar.gz" --strip-components=1 --one-top-level
+}
build() {
cd "$_name-$pkgver"
@@ -48,5 +51,4 @@ package() {
install -Dm 644 README -t "$pkgdir/usr/share/$pkgname/"
install -Dm 644 "build/sphinx/${_name//-/_}.1" -t "$pkgdir/usr/share/man/man1/"
rm -frv "$pkgdir/$site_packages/${_name//-/_}/tests/"
-
}