summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..743021527e9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-wtforms-test
+ pkgdesc = Unit test helpers for WTForms based forms
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://wtforms-test.readthedocs.io
+ arch = any
+ license = BSD
+ depends = python-wtforms
+ source = https://pypi.org/packages/source/W/WTForms-Test/WTForms-Test-0.1.1.tar.gz
+ sha256sums = 869ba4c1c334ff3bcf1e3260e8d547b77e8052f4c92f185d3b1e242ab376ef6f
+
+pkgname = python-wtforms-test
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ffee7ef3304
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=python-wtforms-test
+_pkgname=WTForms-Test
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='Unit test helpers for WTForms based forms'
+arch=('any')
+url="https://wtforms-test.readthedocs.io"
+license=('BSD')
+depends=('python-wtforms')
+
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('869ba4c1c334ff3bcf1e3260e8d547b77e8052f4c92f185d3b1e242ab376ef6f')
+
+build() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}