summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD57
2 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05bd7a243b08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = python-wxpython-git
+ pkgdesc = Python 3 implementation of the WxPython UI library
+ pkgver = 4.2.1.r25.g83db65a2
+ pkgrel = 1
+ url = https://github.com/wxWidgets/Phoenix
+ arch = x86_64
+ license = custom:wxWindows
+ checkdepends = xorg-server-xvfb
+ checkdepends = python-pytest-forked
+ checkdepends = python-numpy
+ makedepends = git
+ makedepends = mesa
+ makedepends = glu
+ makedepends = webkit2gtk
+ makedepends = python-requests
+ makedepends = python-setuptools
+ makedepends = python-attrdict
+ makedepends = sip
+ makedepends = doxygen
+ makedepends = waf
+ depends = wxwidgets-gtk3
+ depends = python-six
+ optdepends = python-pypubsub: Alternative to the deprecated wx.lib.pubsub API
+ provides = python-wxpython
+ conflicts = python-wxpython
+ conflicts = wxpython-phoenix-git
+ replaces = wxpython-phoenix-git
+ source = git+https://github.com/wxWidgets/Phoenix.git
+ source = git+https://github.com/wxWidgets/wxWidgets.git
+ source = git+https://github.com/wxWidgets/nanosvg.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = python-wxpython-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09dc42419c46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Allen M. <ase1590@hotmail.com>
+
+pkgname=python-wxpython-git
+pkgver=4.2.1.r25.g83db65a2
+pkgrel=1
+pkgdesc="Python 3 implementation of the WxPython UI library"
+arch=(x86_64)
+url="https://github.com/wxWidgets/Phoenix"
+license=('custom:wxWindows')
+depends=('wxwidgets-gtk3' 'python-six')
+optdepends=('python-pypubsub: Alternative to the deprecated wx.lib.pubsub API')
+makedepends=(git 'mesa' 'glu' 'webkit2gtk' 'python-requests' 'python-setuptools' 'python-attrdict' 'sip' 'doxygen' 'waf')
+checkdepends=('xorg-server-xvfb' 'python-pytest-forked' 'python-numpy')
+provides=(python-wxpython)
+conflicts=(python-wxpython wxpython-phoenix-git)
+replaces=(wxpython-phoenix-git)
+source=("git+https://github.com/wxWidgets/Phoenix.git"
+ "git+https://github.com/wxWidgets/wxWidgets.git"
+ "git+https://github.com/wxWidgets/nanosvg.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd Phoenix
+ git describe --long --tags --exclude last-sip* | sed 's/^wxPython-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare(){
+ cd Phoenix
+ git submodule init
+ git config submodule.ext/wxWidgets.url "${srcdir}/wxWidgets"
+ git config submodule.ext/nanosvg.url "${srcdir}/nanosvg"
+ git -c protocol.file.allow=always submodule update
+}
+
+build(){
+ cd Phoenix
+ rm -r sip/{cpp,gen}/* # Recreate sip files with current wxWidgets
+ #SIP=/usr/bin/sip DOXYGEN=/usr/bin/doxygen WAF=/usr/bin/waf \
+ python build.py dox etg --nodoc sip build --use_syswx --release
+}
+
+check() {
+ cd Phoenix
+ # there are segfaulting tests so --forked ensures we get sensible results
+ PYTHONPATH=$PWD xvfb-run pytest --forked unittests || echo "==> WARNING: tests usually fail randomly"
+}
+
+package(){
+ cd Phoenix
+ python build.py install --destdir="$pkgdir"
+
+ install -Dm 644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+ find "$pkgdir/usr/lib" -type f | xargs chmod 644
+}