summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD20
2 files changed, 26 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7774b9b0eeab..d284fece3b78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,47 +1,46 @@
# Generated by mksrcinfo v8
-# Tue Aug 18 05:00:02 UTC 2020
+# Sat Dec 12 03:05:39 UTC 2020
pkgbase = python2-aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.18.2
+ pkgver = 3.19.2
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python2
makedepends = python2-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.18.2.tar.gz
- sha256sums = 70c247f9d54b8071d7550127e665a42a837f72812c5a1749ddb17104fbdba8db
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.19.2.tar.gz
+ md5sums = 17c706cf1d2f40ad5809aacabb498464
+ sha256sums = bd5221c26b3c7eb64597c6ae03b76c2025ed210e68d3702819bdfa1afb015230
pkgname = python2-aws-eb-cli
depends = python2
- depends = python2-botocore>=1.15
- depends = python2-botocore<1.16
+ depends = python2-botocore>=1.19.0
+ depends = python2-botocore<1.20.0
depends = python2-cement=2.8.2
- depends = python2-colorama>=0.4
- depends = python2-colorama<1.0
+ depends = python2-colorama>=0.2.5
+ depends = python2-colorama<0.4.4
depends = python2-future>=0.16.0
depends = python2-future<0.17.0
depends = python2-pathspec=0.5.9
depends = python2-dateutil>=2.1
- depends = python2-dateutil<2.8.1
+ depends = python2-dateutil<3.0.0
depends = python2-requests>=2.20.1
- depends = python2-requests<2.21
+ depends = python2-requests<=2.24
depends = python2-setuptools>=20.0
depends = python2-semantic_version=2.5.0
- depends = python2-six>=1.11.0
- depends = python2-six<1.12.0
+ depends = python2-six>=1.12.0
+ depends = python2-six<=1.15.0
depends = python2-termcolor=1.1.0
- depends = python2-urllib3>=1.24.1
- depends = python2-urllib3<1.25
depends = python2-wcwidth>=0.1.7
depends = python2-wcwidth<0.2.0
depends = python2-yaml>=5.3.1
depends = python2-yaml<5.4
+ depends = python2-urllib3>=1.25.4
+ depends = python2-urllib3<1.26
depends = python2-docker-compose>=1.25.2
depends = python2-docker-compose<1.26.0
depends = python2-blessed>=1.9.5
- depends = python2-docutils<0.16
- depends = python2-docutils>=0.10
depends = docker>=3.3.0
depends = python2-requests>=2.14.2
conflicts = aws-eb-cli
diff --git a/PKGBUILD b/PKGBUILD
index 06b9bc1bc342..2f04f27fc455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybasend="${_pybase//-/}"
-pkgver='3.18.2'
+pkgver='3.19.2'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,8 @@ _srcdir="${_pybasend}-${pkgver}"
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybasend: 0:1}/${_pybasend}/${_pybasend}-${pkgver}.tar.gz")
-sha256sums=('70c247f9d54b8071d7550127e665a42a837f72812c5a1749ddb17104fbdba8db')
+md5sums=('17c706cf1d2f40ad5809aacabb498464')
+sha256sums=('bd5221c26b3c7eb64597c6ae03b76c2025ed210e68d3702819bdfa1afb015230')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -44,25 +45,26 @@ _fn_pydepends() {
# Paste in from setup.py. This function does NOT work in zsh.
local _requires="
requires = [
- 'botocore>=1.15,<1.16',
+ 'botocore>=1.19.0,<1.20.0',
'cement==2.8.2',
- 'colorama>=0.4,<1.0', # use the same range that 'docker-compose' uses
+ 'colorama>=0.2.5,<0.4.4', # use the same range that 'docker-compose' uses
'future>=0.16.0,<0.17.0',
'pathspec==0.5.9',
- 'python-dateutil>=2.1,<2.8.1', # use the same range that 'botocore' uses
- 'requests>=2.20.1,<2.21',
+ 'python-dateutil>=2.1,<3.0.0', # use the same range that 'botocore' uses
+ 'requests>=2.20.1,<=2.24',
'setuptools >= 20.0',
'semantic_version == 2.5.0',
- 'six>=1.11.0,<1.12.0',
+ 'six>=1.12.0,<=1.15.0',
'termcolor == 1.1.0',
- 'urllib3>=1.24.1,<1.25',
'wcwidth>=0.1.7,<0.2.0',
#found further down in setup.py
'PyYAML>=5.3.1,<5.4', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
+ 'urllib3>=1.25.4,<1.26',
+ # use the same ranges as 'docker-py':
'docker-compose >= 1.25.2, < 1.26.0',
'blessed>=1.9.5',
#Part of Botocore
- 'docutils<0.16,>=0.10'
+ #'docutils<0.16,>=0.10'
]
"
# Convert requires=[] to local _requires=()