summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39c03de3f957
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-cjuman
+ pkgdesc = A Python bindings of JUMAN, A Japanese Morphological Analyzer
+ pkgver = 0.1.0
+ pkgrel = 4
+ url = http://app-dist.khlog.net/software/python-cjuman/
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = juman
+ depends = git
+ depends = python2
+ source = git+https://github.com/chezou/cJuman-installer.git
+ sha1sums = SKIP
+
+pkgname = python2-cjuman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20384a1b351f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: nosada <ngsksdt@gmail.com>
+
+pkgname=python2-cjuman
+pkgver=0.1.0
+pkgrel=4
+pkgdesc="A Python bindings of JUMAN, A Japanese Morphological Analyzer"
+url="http://app-dist.khlog.net/software/python-cjuman/"
+arch=('i686' 'x86_64')
+license=('unknown')
+depends=('juman' 'git' 'python2')
+
+# this PKGBUILD uses cJuman installer (https://github.com/chezou/cJuman-installer) .
+source=('git+https://github.com/chezou/cJuman-installer.git')
+_pkgname="cJuman-installer"
+sha1sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${_pkgname}
+
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}
+
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: