summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8134f165519b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-cliff-liberty
+ pkgdesc = Command Line Interface Formulation Framework
+ pkgver = 1.12.0
+ pkgrel = 1
+ url = https://github.com/openstack/cliff
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/c/cliff/cliff-1.12.0.tar.gz
+ sha256sums = 7609abc1789522fc4e228ea5567a9fd1db3963850396178adca3332cdd9c929a
+
+pkgname = python2-cliff-liberty
+ depends = python2-cmd2>=0.6.7
+ depends = python2-prettytable>=0.7
+ depends = python2-pyparsing>=2.0.1
+ depends = python2-six>=1.9.0
+ depends = python2-stevedore-openstack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4843a21eb12d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Erhan SAHIN <erhan@ssahin.net>
+
+pkgname=("python2-cliff-liberty")
+pkgver="1.12.0"
+pkgrel="1"
+pkgdesc="Command Line Interface Formulation Framework"
+arch=("any")
+url="https://github.com/openstack/cliff"
+license=("Apache")
+makedepends=("python2-setuptools")
+source=("https://pypi.python.org/packages/source/c/cliff/cliff-${pkgver}.tar.gz")
+sha256sums=('7609abc1789522fc4e228ea5567a9fd1db3963850396178adca3332cdd9c929a')
+
+package() {
+ depends=("python2-cmd2>=0.6.7"
+ "python2-prettytable>=0.7"
+ "python2-pyparsing>=2.0.1"
+ "python2-six>=1.9.0"
+ "python2-stevedore-openstack")
+ cd "${srcdir}/cliff-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}