summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD69
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5abc41b3546b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-climate-git
+ pkgdesc = Command line utilities for Python 2
+ pkgver = 0.4.3.r53.6ccbff8
+ pkgrel = 2
+ url = https://github.com/lmjohns3/py-cli/
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-plac
+ provides = python2-climate
+ conflicts = python2-climate
+ source = git+https://github.com/lmjohns3/py-cli
+ sha256sums = SKIP
+
+pkgname = python2-climate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfcb677944d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: jyantis <yantis@yantis.net>
+
+pkgname=python2-climate-git
+pkgver=0.4.3.r53.6ccbff8
+pkgrel=2
+pkgdesc='Command line utilities for Python 2'
+arch=('any')
+url='https://github.com/lmjohns3/py-cli/'
+license=('custom')
+depends=('python2' 'python2-plac')
+source=('git+https://github.com/lmjohns3/py-cli')
+sha256sums=('SKIP')
+makedepends=('git' 'python2-setuptools')
+provides=('python2-climate')
+conflicts=('python2-climate')
+
+pkgver() {
+ cd py-cli
+ set -o pipefail
+ _gitversion=$( git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
+
+ # If there is a setup.py then pull the version tag from the file
+ if [ -f "setup.py" ]; then
+ if grep --quiet "version = " setup.py; then
+ printf "%s.%s" "$(grep -R "version = " setup.py | awk -F\' '{print $2}')" $_gitversion | sed 's/-/./g'
+ elif grep --quiet "version=" setup.py; then
+ printf "%s.%s" "$(grep -R "version=" setup.py | awk -F\' '{print $2}')" $_gitversion | sed 's/-/./g'
+ else
+ printf "%s" $_gitversion
+ fi
+ else
+ printf "%s" $_gitversion
+ fi
+}
+
+build() {
+ cd py-cli
+
+ # Patch any #!/usr/bin/python to #!/usr/bin/python2
+ for file in $(find . -name '*.py' -print); do
+ sed -r -i 's_^#!.*/usr/bin/python(\s|$)_#!/usr/bin/python2_' $file
+ sed -r -i 's_^#!.*/usr/bin/env(\s)*python(\s|$)_#!/usr/bin/env python2_' $file
+ done
+
+ python2 setup.py build
+}
+
+check() {
+ cd py-cli
+ python2 setup.py test --verbose
+}
+
+package() {
+ cd py-cli
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+# vim:set ts=2 sw=2 et: