summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7d230c3d3c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-constantly
+ pkgdesc = Symbolic constants in Python
+ pkgver = 15.1.0
+ pkgrel = 9
+ url = https://github.com/twisted/constantly
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ source = python2-constantly-15.1.0.tgz::https://github.com/twisted/constantly/archive/refs/tags/15.1.0.tar.gz
+ sha512sums = eeaa74552fe8e01c40566ac3c8b3d41085f800863ac516e30fe1242f40d3401e4e872279149776f29d3ba78a7a16337a794ad26230efab4dd1847d42bffa81ce
+
+pkgname = python2-constantly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..267324c2ae8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+
+pkgname=python2-constantly
+pkgver=15.1.0
+pkgrel=9
+pkgdesc='Symbolic constants in Python'
+arch=('any')
+license=('MIT')
+url='https://github.com/twisted/constantly'
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("$pkgname-$pkgver.tgz::https://github.com/twisted/constantly/archive/refs/tags/$pkgver.tar.gz")
+sha512sums=('eeaa74552fe8e01c40566ac3c8b3d41085f800863ac516e30fe1242f40d3401e4e872279149776f29d3ba78a7a16337a794ad26230efab4dd1847d42bffa81ce')
+
+build() {
+ cd constantly-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd constantly-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}