summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8731fb4bdd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-cryptacular
+ pkgdesc = A password hashing framework with bcrypt and pbkdf2.
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/cryptacular/
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ depends = python2
+ source = http://pypi.python.org/packages/source/c/cryptacular/cryptacular-1.4.1.tar.gz
+ md5sums = fe12232ac660185186dd8057d8ca7b0e
+
+pkgname = python2-cryptacular
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01e2ab18c41c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Samantha Baldwin <fuhsaz 'plus' aur 'at' cryptic 'dot' li>
+
+_name=cryptacular
+pkgname=python2-${_name}
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="A password hashing framework with bcrypt and pbkdf2."
+arch=('any')
+url="http://pypi.python.org/pypi/cryptacular/"
+license=('MIT')
+depends=('python2')
+makedepends=('python2-distribute')
+source=("http://pypi.python.org/packages/source/c/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=(fe12232ac660185186dd8057d8ca7b0e)
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python2 setup.py install --prefix=/usr --root=${pkgdir} --optimize=1 || return 1
+}