summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04ba48a69112..07127239653f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-dbus
- pkgdesc = Python2 bindings for DBUS
+ pkgdesc = Python bindings for DBUS (Legacy Python 2 version)
pkgver = 1.2.18
- pkgrel = 2
+ pkgrel = 3
url = https://www.freedesktop.org/wiki/Software/DBusBindings
arch = x86_64
license = GPL
@@ -11,8 +11,6 @@ pkgbase = python2-dbus
depends = dbus
depends = glib2
depends = python2
- depends = python-dbus-common<1.3
- depends = python-dbus-common>=1.2
source = https://dbus.freedesktop.org/releases/dbus-python/dbus-python-1.2.18.tar.gz
sha256sums = 92bdd1e68b45596c833307a5ff4b217ee6929a1502f5341bae28fd120acf7260
diff --git a/PKGBUILD b/PKGBUILD
index 19b05fc81d21..d6a29cd7354b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
pkgname=python2-dbus
_pkgname=dbus-python
+# Do NOT update this further. Support for Python 2 was dropped with dbus-python 1.3.0
pkgver=1.2.18
-pkgrel=2
-pkgdesc="Python2 bindings for DBUS"
+pkgrel=3
+pkgdesc="Python bindings for DBUS (Legacy Python 2 version)"
url="https://www.freedesktop.org/wiki/Software/DBusBindings"
arch=(x86_64)
license=('GPL' 'LGPL')
-depends=('dbus' 'glib2' 'python2' 'python-dbus-common<1.3' 'python-dbus-common>=1.2')
+depends=('dbus' 'glib2' 'python2')
makedepends=('autoconf-archive' 'automake')
source=(https://dbus.freedesktop.org/releases/${_pkgname}/${_pkgname}-${pkgver}.tar.gz)
sha256sums=('92bdd1e68b45596c833307a5ff4b217ee6929a1502f5341bae28fd120acf7260')
@@ -29,7 +30,11 @@ package() {
cd $_pkgname-$pkgver
make DESTDIR="${pkgdir}" install
- rm -rf "${pkgdir}/usr/share"
+ # dbus-python.h and dbus-python.pc are also provided by the dbus-python package in the official
+ # repositories and shipping them in both packages would result in a collision. Since v1.3.0 dropped
+ # support for Python 2 we can't just depend on the right version of dbus-python and expect the
+ # files to stay compatible either.
+ # Simply stop shipping them entirely and pray nobody actually needs them from us.
rm -r "${pkgdir}/usr/include"
rm -r "${pkgdir}/usr/lib/pkgconfig"
}