summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7d9599ee3d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-dfdatetime
+ pkgdesc = Digital Forensics date and time
+ pkgver = 20160323
+ pkgrel = 1
+ url = https://github.com/log2timeline/dfdatetime
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = python2
+ source = https://github.com/log2timeline/dfdatetime/archive/20160323.zip
+ md5sums = 6baa6610bba5906e42925315a4b00932
+
+pkgname = python2-dfdatetime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f70deb74bd1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=python2-dfdatetime
+_realname=dfdatetime
+pkgver=20160323
+pkgrel=1
+pkgdesc="Digital Forensics date and time"
+url="https://github.com/log2timeline/dfdatetime"
+license=('Apache')
+arch=('i686' 'x86_64')
+depends=('python2')
+options=()
+source=(https://github.com/log2timeline/${_realname}/archive/${pkgver}.zip)
+
+build() {
+ export PYTHON=python2
+ cd "$srcdir"/${_realname}-${pkgver}
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir"/${_realname}-${pkgver}
+ python2 setup.py install --root="${pkgdir}"
+}
+md5sums=('6baa6610bba5906e42925315a4b00932')