summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 16 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1ad0f7658b0..d237b6f8894b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Sep 8 23:49:58 UTC 2016
-pkgbase = python-flask-bcrypt
+pkgbase = python2-flask-bcrypt
pkgdesc = Bcrypt hashing for Flask
pkgver = 0.7.1
- pkgrel = 1
- url = https://pythonhosted.org/Flask-Bcrypt/
+ pkgrel = 2
+ url = http://flask-bcrypt.readthedocs.io/en/latest/
arch = any
license = BSD
makedepends = python2-setuptools
- makedepends = python-setuptools
- source = python-flask-bcrypt-0.7.1.tar.gz::https://github.com/maxcountryman/flask-bcrypt/archive/0.7.1.tar.gz
- md5sums = 52747432432d6057fac3ed365c13a466
-
-pkgname = python2-flask-bcrypt
depends = python2-flask
depends = python2-bcrypt
+ source = -0.7.1.tar.gz::https://github.com/maxcountryman/flask-bcrypt/archive/0.7.1.tar.gz
+ md5sums = 52747432432d6057fac3ed365c13a466
-pkgname = python-flask-bcrypt
- depends = python-flask
- depends = python-bcrypt
+pkgname = python2-flask-bcrypt
diff --git a/PKGBUILD b/PKGBUILD
index 8ff46e8e7575..f90dd8bd0524 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,17 @@
+# Maintainer: jakob <grandchild@gmx.net>
+# Contributor: TrialnError <autumn-wind@web.de>
+# Contributor: ser <arch@random.re>
-_pipname=Flask-Bcrypt
-pkgbase=python-flask-bcrypt
-pkgname=('python2-flask-bcrypt' 'python-flask-bcrypt')
+_pipname=flask-bcrypt
+pkgname=python2-flask-bcrypt
pkgver=0.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="Bcrypt hashing for Flask"
arch=('any')
-url="https://pythonhosted.org/Flask-Bcrypt/"
+url="http://flask-bcrypt.readthedocs.io/en/latest/"
license=('BSD')
-makedepends=('python2-setuptools' 'python-setuptools')
+depends=('python2-flask' 'python2-bcrypt')
+makedepends=('python2-setuptools')
source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/maxcountryman/flask-bcrypt/archive/${pkgver}.tar.gz")
md5sums=('52747432432d6057fac3ed365c13a466')
@@ -17,22 +20,10 @@ prepare() {
cp -R $_pipname-$pkgver python2-$_pipname-$pkgver
}
-package_python2-flask-bcrypt() {
-depends=('python2-flask' 'python2-bcrypt')
-
+package() {
cd python2-$_pipname-$pkgver
python2 setup.py install --root="$pkgdir/" --optimize=1
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
install -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname
}
-
-package_python-flask-bcrypt() {
-depends=('python-flask' 'python-bcrypt')
-
- cd $_pipname-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1
-
- mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
- install -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname
-}