summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8df58de25e48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-funcy
+ pkgdesc = Pyhton2 funcy library.
+ pkgver = 1.12
+ pkgrel = 1
+ url = https://github.com/Suor/funcy
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python2-pip
+ depends = python2
+ source = https://github.com/Suor/funcy/archive/1.12.tar.gz
+ sha1sums = ebdd0f28763930e94f48dac54afe44834c51535e
+
+pkgname = python2-funcy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ac81709db22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
+
+pkgname=python2-funcy
+pkgver=1.12
+pkgrel=1
+
+pkgdesc='Pyhton2 funcy library.'
+url='https://github.com/Suor/funcy'
+arch=('i686' 'x86_64')
+license=('GPL')
+
+depends=('python2')
+makedepends=('python2-pip')
+
+source=('https://github.com/Suor/funcy/archive/1.12.tar.gz')
+sha1sums=('ebdd0f28763930e94f48dac54afe44834c51535e')
+
+
+build()
+{
+ cd $srcdir/funcy-1.12
+}
+
+
+package()
+{
+ cd $srcdir/funcy-1.12
+ pip2.7 install --root=$pkgdir funcy
+}