summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2ccb9ed6101
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-gcm
+ pkgdesc = Python client for Google Cloud Messaging for Android (GCM)
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/geeknam/python-gcm
+ arch = any
+ license = custom
+ makedepends = python2-setuptools
+ depends = python2
+ source = http://pypi.python.org/packages/source/p/python-gcm/python-gcm-0.1.5.tar.gz
+ sha512sums = bb7993d9674ddb6a5b2296105e0ea4ac4b1e980d7078922a8e9cf20c3e4ab60bc3d8b04ee417a9df93fc9e13a5d26908fe4e370b2841e214e114f0fa8fea0668
+
+pkgname = python2-gcm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..107cc3cfbeab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+
+pkgname=python2-gcm
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="Python client for Google Cloud Messaging for Android (GCM)"
+arch=('any')
+url="https://github.com/geeknam/python-gcm"
+license=('custom')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("http://pypi.python.org/packages/source/p/python-gcm/python-gcm-$pkgver.tar.gz")
+
+build() {
+ cd python-gcm-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd python-gcm-$pkgver
+ python2 setup.py install --root="$pkgdir/"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+sha512sums=('bb7993d9674ddb6a5b2296105e0ea4ac4b1e980d7078922a8e9cf20c3e4ab60bc3d8b04ee417a9df93fc9e13a5d26908fe4e370b2841e214e114f0fa8fea0668')