summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c45a01de292
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-gevent-websocket
+ pkgdesc = Websocket handler for the gevent pywsgi server, a Python network library.
+ pkgver = 0.9.5
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/gevent-websocket
+ arch = any
+ license = Apache
+ makedepends = cython2
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-gevent
+ optdepends = python2-ujson: Ultra-fast JSON encoder and decoder for Python.
+ source = https://pypi.python.org/packages/source/g/gevent-websocket/gevent-websocket-0.9.5.tar.gz
+ md5sums = 03a8473b9a61426b0ef6094319141389
+
+pkgname = python2-gevent-websocket
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08ec78b6cf75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Benjamin A. Shelton <zancarius@gmail.com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+# Source: https://github.com/zancarius/archlinux-pkgbuilds
+
+pkgname=python2-gevent-websocket
+pkgver=0.9.5
+pkgrel=1
+pkgdesc="Websocket handler for the gevent pywsgi server, a Python network library."
+arch=(any)
+url="http://pypi.python.org/pypi/gevent-websocket"
+license=(Apache)
+depends=(python2 python2-gevent)
+makedepends=(cython2 python2-setuptools)
+source=("https://pypi.python.org/packages/source/g/gevent-websocket/gevent-websocket-${pkgver}.tar.gz")
+md5sums=(03a8473b9a61426b0ef6094319141389)
+optdepends=(
+ 'python2-ujson: Ultra-fast JSON encoder and decoder for Python.'
+)
+
+package () {
+
+ cd "${srcdir}/gevent-websocket-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm0644 "${srcdir}/gevent-websocket-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}