summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..739dad8b62cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-grapevine
+ pkgdesc = Iterator pipelines for Python
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://jwilk.net/software/python-grapevine
+ arch = any
+ license = MIT
+ depends = python2
+ source = https://pypi.python.org/packages/source/g/grapevine/grapevine-1.0.tar.gz
+ md5sums = 689dabfb162f253b1718562cf16f9e46
+
+pkgname = python2-grapevine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b38c936fd1c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: S.Leduc <sebastien@sleduc.fr>
+
+pkgname=python2-grapevine
+_realname=grapevine
+pkgver=1.0
+pkgrel=1
+pkgdesc="Iterator pipelines for Python"
+arch=("any")
+url="http://jwilk.net/software/python-grapevine"
+license=('MIT')
+depends=('python2')
+source=("https://pypi.python.org/packages/source/g/$_realname/$_realname-$pkgver.tar.gz")
+md5sums=('689dabfb162f253b1718562cf16f9e46')
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: