summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1b5afa3e3dd..afa48b06bd7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-graph-tool
pkgdesc = A Python module for manipulation and statistical analysis of graphs
- pkgver = 2.29
- pkgrel = 2
+ pkgver = 2.30
+ pkgrel = 1
url = https://graph-tool.skewed.de
arch = i686
arch = x86_64
@@ -19,8 +19,8 @@ pkgbase = python2-graph-tool
optdepends = graphviz: graph layout
optdepends = python2-matplotlib: graph drawing
options = !libtool
- source = https://downloads.skewed.de/graph-tool/graph-tool-2.29.tar.bz2
- sha256sums = 6c0c4336bed6e2f79c91ace6d6914145ee03d0bd5025473b5918aec2b0657f7a
+ source = https://downloads.skewed.de/graph-tool/graph-tool-2.30.tar.bz2
+ sha256sums = 823cf3374b08fbfe8f580d08ae063913d021ff92f8ef1365d317e8ea38ecc8bf
pkgname = python2-graph-tool
diff --git a/PKGBUILD b/PKGBUILD
index 0c2f17552b33..13d870fba19a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Remove the --enable-openmp flag below if you do not want parallelization.
pkgname=python2-graph-tool
-pkgver=2.29
-pkgrel=2
+pkgver=2.30
+pkgrel=1
pkgdesc='A Python module for manipulation and statistical analysis of graphs'
arch=('i686' 'x86_64')
url='https://graph-tool.skewed.de'
@@ -15,11 +15,10 @@ optdepends=('graphviz: graph layout'
'python2-matplotlib: graph drawing')
options=(!libtool)
source=("https://downloads.skewed.de/graph-tool/graph-tool-$pkgver.tar.bz2")
-sha256sums=('6c0c4336bed6e2f79c91ace6d6914145ee03d0bd5025473b5918aec2b0657f7a')
+sha256sums=('823cf3374b08fbfe8f580d08ae063913d021ff92f8ef1365d317e8ea38ecc8bf')
prepare() {
cd "$srcdir/graph-tool-$pkgver"
- export CPPFLAGS="$CPPFLAGS -DHAVE_BOOST_COROUTINE" # workaround for bug in boost 1.72
./configure --enable-openmp --prefix=/usr --docdir="/usr/share/doc/$pkgname" PYTHON=python2
}