summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..627e9b719cfb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python2-leap.pixelated-www
+ pkgdesc = Static Assets for the Pixelated User Agent UI
+ pkgver = 1.0.201709121424
+ pkgrel = 1
+ url = http://github.com/leapcode/pixelated-user-agent
+ arch = any
+ license = AGPL3
+ source = https://files.pythonhosted.org/packages/source/l/leap.pixelated-www/leap.pixelated-www-1.0.201709121424.tar.gz
+ sha256sums = 142477d3fe31921af2bfbbec4c7fe9472edf8c15e5c5317f96631a6b66398f0f
+
+pkgname = python2-leap.pixelated-www
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a6c22289f8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Felix Höffken <fupduck at sacknagel dot com>
+
+_srcname=leap.pixelated-www
+pkgname=python2-$_srcname
+pkgver=1.0.201709121424
+pkgrel=1
+pkgdesc='Static Assets for the Pixelated User Agent UI'
+arch=('any')
+url='http://github.com/leapcode/pixelated-user-agent'
+license=('AGPL3')
+
+source=("https://files.pythonhosted.org/packages/source/${_srcname::1}/${_srcname}/${_srcname}-${pkgver}.tar.gz")
+sha256sums=('142477d3fe31921af2bfbbec4c7fe9472edf8c15e5c5317f96631a6b66398f0f')
+
+build() {
+ cd "$srcdir/$_srcname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_srcname-$pkgver"
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+}