summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28a3f5181913
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-libevt
+ pkgdesc = Library and tools to access the Windows Event Log (EVT) format.
+ pkgver = 20151206
+ pkgrel = 1
+ url = https://github.com/libyal/libevt/
+ arch = any
+ license = LGPLv3+
+ makedepends = python2
+ makedepends = gcc
+ depends = python2
+ source = https://pypi.python.org/packages/source/l/libevt-python/libevt-python-20151206.tar.gz#md5=346f2e6cb320d6e3c1861cba3e924cf8
+ md5sums = 346f2e6cb320d6e3c1861cba3e924cf8
+
+pkgname = python2-libevt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..d87518d3c2d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=python2-libevt
+_pkgcode=libevt
+pkgver=20151206
+pkgrel=1
+pkgdesc="Library and tools to access the Windows Event Log (EVT) format."
+url="https://github.com/libyal/libevt/"
+arch=('any')
+license=('LGPLv3+')
+
+depends=('python2')
+makedepends=('python2' 'gcc')
+
+md5sum=346f2e6cb320d6e3c1861cba3e924cf8
+source=(https://pypi.python.org/packages/source/l/$_pkgcode-python/$_pkgcode-python-$pkgver.tar.gz#md5=$md5sum)
+md5sums=($md5sum)
+
+build() {
+ cd $srcdir/${_pkgcode}-${pkgver}
+
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/${_pkgcode}-${pkgver}
+ python2 setup.py install --root="${pkgdir}"
+}